practiX

Upgrades


HIE version 2.2 now available for upgrade - 3/06/2016


IMPORTANT ADVISORY CSC - HIE 2.2 upgrade

All sites requiring access to the eHealth incentives program (My Health Record) can now book an upgrade for HIE 2.2 with our help desk. This advisory applies to your practice if you require any eHealth functionality. For avoidance of doubt, these functions are:


- Health Identifiers


- Searching for Patient IHI records


- Searching for HPI-Os (either for contacts or sites)


- PCEHR Interactions


- Upload of documents to PCEHR (Shared Health Summary and Event Summary)


- Looking up a patient’s PCEHR


- Assisted Registration of a Patient


- Electronic scripts NPDR


Please Note: System downtime is NOT required for this upgrade. CHARGES DO APPLY for upgrades booked outside of normal support hours. Please see the upgrade booking request form for more information

practiX version 1.43.1 now available for upgrade - 10/11/2014


IMPORTANT ADVISORY CSC - practiX 1.43.1 upgrade

All sites using Medicare online for any type of billing will need to upgrade to practiX 1.43.1 due to privacy declaration changes introduced by Medicare. These changes are effective from 1st of March 2015 and it is important that all affected clients upgrade prior to this date.


To upgrade to the latest version of practiX, complete an upgrade booking form, please complete all areas of the form before submitting via email or fax to the iResponse Team.


Please Note: CHARGES DO APPLY for upgrades booked outside of normal support hours. Please see the upgrade booking request form for more information